1 2 3 4 5 6 48
7 replies

Extruder clicking when printing

Created by: Atomic Powered 3D | Views: 197 | Last reply July 16, 2017 by Peter k
18 replies

Extruder motor swap

Created by: BV | Views: 192 | Last reply July 16, 2017 by BV
0 replies

xy issue

Created by: Brian | Views: 40 | Last post July 15, 2017 by Brian
28 replies

Extruder microstepping

Created by: psanyi | Views: 2646 | Last reply July 15, 2017 by BV
1 replies

Craftbot Bed Resonance

Created by: BV | Views: 44 | Last reply July 15, 2017 by BV
1 replies

Regular glass & turpentine

Created by: Henk Jan O | Views: 45 | Last reply July 13, 2017 by psanyi
4 replies
5 replies

PETG, not sticking to bed and cloging

Created by: Joe Medina | Views: 162 | Last reply July 8, 2017 by Joe Medina
2 replies

Craftbot + theft signaling

Created by: Maurizio Maggi | Views: 92 | Last reply July 3, 2017 by Maurizio Maggi
6 replies

Where to buy a new hotend?

Created by: Israel lanctot | Views: 107 | Last reply July 3, 2017 by Edina Fajcsi
5 replies

PRINTinZ

Created by: BV | Views: 257 | Last reply July 1, 2017 by Israel lanctot
1 replies

Temperatur sensor came lose

Created by: Marius | Views: 63 | Last reply June 30, 2017 by Pierre
44 replies

Any thoughts on my dual extruder ?

Created by: BV | Views: 1196 | Last reply June 28, 2017 by BV
8 replies

Craftbot 2 finally gone

Created by: Justin Leininger | Views: 206 | Last reply June 28, 2017 by Pierre
1 2 3 4 5 6 48
To start a discussion or reply to a post please Login or Create an account.